xLEaP Problems

xLEaP linking fails on Linux due to dl* undefined references

1. The error message:

/usr/X11R6/lib/libX11.a(XlcDL.o): In function `try_both_dlsym':
XlcDL.o(.text+0xe2): undefined reference to `dlsym'
XlcDL.o(.text+0x107): undefined reference to `dlsym'
/usr/X11R6/lib/libX11.a(XlcDL.o): In function `open_object':
XlcDL.o(.text+0x557): undefined reference to `dlopen'
/usr/X11R6/lib/libX11.a(XlcDL.o): In function `close_object':
XlcDL.o(.text+0x5cd): undefined reference to `dlclose'
collect2: ld returned 1 exit status
make: *** [xaLeap] Error 1

2. The fix:

Insert -ldl after -lX11 in the definition of XALEAP_LIB in

XALEAP_LIB = ../Xraw/libXaw.a ../Wc/libWcLeap.a ../Xpm/libXpm.a \
   ../Xmu/libXmu.a -L$(XHOME)/lib -lXt -lXext -lSM -lICE -lX11 -lm -lpthread


XALEAP_LIB = ../Xraw/libXaw.a ../Wc/libWcLeap.a ../Xpm/libXpm.a \
   ../Xmu/libXmu.a -L$(XHOME)/lib -lXt -lXext -lSM -lICE -lX11 -lm -lpthread -ldl

3. The diagnosis:

Some libX11.* depend on libdl.*.  We do not know exactly which
distributions are problematic.  This was detected in Amber8 
./configure -static ifc7
Linux bohr 2.4.18-5smp #1 SMP Mon Jun 10 15:19:40 EDT 2002 i686 unknown
Red Hat Linux release 7.3 (Valhalla)
1264 -rw-r--r--    1 root     root      1286396 Apr 18  2002 /usr/X11R6/lib/libX11.a
using either
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)
Reading specs from /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1.1/specs
Configured with: ../gcc-3.1.1/configure 
Thread model: single
gcc version 3.1.1

xLEaP menu selections do not work.


    On some installations of xLEAP in Linux you need to make sure that 
the NUM lock and probably the CAPS lock button are not active. I'm not 
entirely clear why but it works for me. It has been mentioned once or 
twice on the list but is very hard to find in the email archive.

Hope this helps,

Don Thomas

Stephen P. Molnar, Ph.D. wrote:

>I have just compiled amber v7 with the intel fortran compiler in SuSE v8.1 
>Linux.  No problems or errors were reported.
>The tests were run without problems.  However, when I attempt to use the gui 
>for LEAP I enconter a problem.  The gui opens without any problems. All of 
>the pull down menus are functional, i.e., they open when I click on them, but 
>none of the menu selections  work.
>Thanks in advance.

xLEaP text is not visible.

Somebody gave me this tip which worked on a couple computers
I have run across running RedHat:

Edit the file XaLeap_wcl (in $AMBERHOME/dat) and change the line:

XaLeap*commands.text*font: *-*-medium-r-*-14-*-m-*


XaLeap*commands.text*font: -*-helvetica-medium-r-*-*-14-*-*-*-*-*-*-*

But this is only sometimes needed.  There must be some fonts that don't
necessarily get installed by default?

        Hope that helps - John Bushnell

On Mon, 29 Sep 2003, Jiang Pengju wrote:

> Dear Sir or Madam,
>      I have encounter a problem with my xleap. My
> operation system is RedHat Linux 9.0 and I have
> compiled the amber7 with default compiler. And there
> is no warning message or error report. But when I
> start xleap, I can not see the text in the window.
> Yours sincerely,
> Pengju Jiang

The command describe {} fails (usually crashes) in LEaP, both tleap and xleap.

Do not enter that command.
This is a known low priority bug.

xLEaP complains Wcl Error: WcWidgetCreation(xaLeap) - Failed.

On Wed, Oct 02, 2002, Mark C. Ballew wrote:

> I'm having a problem getting xleap to run (Amber 7). When I run xleap, I get
> the following error:
> walnut-0:1010 /home/local/amber7/exe> xleap

> Wcl Error: WcWidgetCreation(xaLeap) - Failed
>     Problem: No children could be created from Xrm database.
>     Possible: Resource file not found
>                 user environment:
>                         XENVIRONMENT is not set,
>                         XAPPLRESDIR not terminated with '/'
>                 user environment or installation:
>                         $XENVIRONMENT/XaLeap does not exist.
>     Possible: top level widget in resource file not named 'xaLeap'
> Error: Shell widget xaLeap has zero width and/or height
> Any ideas? Sounds like something to do with .Xdefaults. I am running Redhat
> 7.2 on a i386.

It's hard to know what is wrong. Here's some things to check:

1. Do you have a file called XaLeap_wcl (of non-zero length) in
   $AMBERHOME/dat. Is your $AMBERHOME environment variable set?

2. You can manually "setenv XENVIRONMENT $AMBERHOME/dat/XaLeap_wcl" and
then run "xaLeap" (this is what the xleap script does for you). Does this

3. You could reinstall leap and look carefully at the log file to see if
there were any errors in the installation step.

..good luck...dac 

Last modified: .